BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 23 ]  На страницу 1, 2  След.
Автор Сообщение
 Заголовок сообщения: Не поднимается Xorg, черный экран
СообщениеДобавлено: Пн 29 июн, 2015 4:29 pm 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
Уважаемые форумчане прошу помочь новичку.
ОС- 10.1
ноутбук Асус N73JF - ЦП: Core i5 560M, NVIDIA GeForce GT 425M и GMA HD 5700MHD.
Проблема в том что не запускаются иксы.
Во время установки руководствовался этим роликом: https://youtu.be/wI_ZI0Tk_Mo
Поставит xorg, slim и mate
поправил rc.conf и ./xinitrc
Перегружаюсь, а графическая оболочка не поднимается...
Далее решил сконфигурировать X11, ориентировался на https://www.freebsd.org/doc/ru/books/handbook/x-config.html
Пробую выполнить:
Код:
 # Xorg -configure

Выходит черный экран и висит.
Пробую выполнить:
Код:
# Xorg -config xorg.conf.new или # Xorg -config xorg.conf.new -retro

Так же выходит черный экран и висит.
на Ctrl+Alt+Backspace не реагирует, только Ctrl+Alt+Del
на команду
Код:
# setxkbmap -option terminate:ctrl_alt_bksp

выходит: cannot open display default display

Чем больше гуглю тем более закапываюсь в дебри, помоги пожалуйста :oops:

Заранее благодарен за помощь!

Что выдает в Xorg.0.log:
Код:
Paste2

    Create Paste
    Followup Paste
    QR

[    34.455]
X.Org X Server 1.14.7
Release Date: 2014-06-05
[    34.455] X Protocol Version 11, Revision 0
[    34.455] Build Operating System: FreeBSD 10.1-RELEASE-p13 amd64
[    34.455] Current Operating System: FreeBSD Fria 10.1-RELEASE-p10 FreeBSD 10.1-RELEASE-p10 #0: Wed May 13 06:54:13 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
[    34.455] Build Date: 18 June 2015  06:37:51PM
[    34.455] 
[    34.455] Current version of pixman: 0.32.6
[    34.455]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    34.455] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    34.455] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun 29 14:20:27 2015
[    34.549] (II) Loader magic: 0x7f9b60
[    34.549] (II) Module ABI versions:
[    34.549]    X.Org ANSI C Emulation: 0.4
[    34.549]    X.Org Video Driver: 14.1
[    34.549]    X.Org XInput driver : 19.1
[    34.549]    X.Org Server Extension : 7.0
[    34.549] (!!) More than one possible primary device found
[    34.549] (--) PCI: (0:0:2:0) 8086:0046:1043:1512 rev 24, Mem @ 0xd3400000/4194304, 0xb0000000/268435456, I/O @ 0x0000e080/8, BIOS @ 0x????????/65536
[    34.549] (--) PCI: (0:1:0:0) 10de:0df0:1043:1512 rev 161, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/65536
[    34.549] (==) Using default built-in configuration (21 lines)
[    34.549] (==) --- Start of built-in configuration ---
[    34.549]    Section "Device"
[    34.549]       Identifier   "Builtin Default vesa Device 0"
[    34.549]       Driver   "vesa"
[    34.549]    EndSection
[    34.549]    Section "Screen"
[    34.549]       Identifier   "Builtin Default vesa Screen 0"
[    34.549]       Device   "Builtin Default vesa Device 0"
[    34.549]    EndSection
[    34.549]    Section "Device"
[    34.549]       Identifier   "Builtin Default fbdev Device 0"
[    34.549]       Driver   "fbdev"
[    34.549]    EndSection
[    34.549]    Section "Screen"
[    34.549]       Identifier   "Builtin Default fbdev Screen 0"
[    34.549]       Device   "Builtin Default fbdev Device 0"
[    34.549]    EndSection
[    34.549]    Section "ServerLayout"
[    34.549]       Identifier   "Builtin Default Layout"
[    34.549]       Screen   "Builtin Default vesa Screen 0"
[    34.549]       Screen   "Builtin Default fbdev Screen 0"
[    34.549]    EndSection
[    34.549] (==) --- End of built-in configuration ---
[    34.549] (==) ServerLayout "Builtin Default Layout"
[    34.549] (**) |-->Screen "Builtin Default vesa Screen 0" (0)
[    34.549] (**) |   |-->Monitor "<default monitor>"
[    34.566] (**) |   |-->Device "Builtin Default vesa Device 0"
[    34.566] (==) No monitor specified for screen "Builtin Default vesa Screen 0".
   Using a default monitor configuration.
[    34.566] (**) |-->Screen "Builtin Default fbdev Screen 0" (1)
[    34.566] (**) |   |-->Monitor "<default monitor>"
[    34.566] (**) |   |-->Device "Builtin Default fbdev Device 0"
[    34.566] (==) No monitor specified for screen "Builtin Default fbdev Screen 0".
   Using a default monitor configuration.
[    34.566] (==) Automatically adding devices
[    34.566] (==) Automatically enabling devices
[    34.566] (==) Not automatically adding GPU devices
[    34.695] (==) FontPath set to:
   /usr/local/share/fonts/misc/,
   /usr/local/share/fonts/TTF/,
   /usr/local/share/fonts/OTF/,
   /usr/local/share/fonts/Type1/,
   /usr/local/share/fonts/100dpi/,
   /usr/local/share/fonts/75dpi/
[    34.696] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[    34.696] (II) The server relies on devd to provide the list of input devices.
   If no devices become available, reconfigure devd or disable AutoAddDevices.
[    34.696] Initializing built-in extension Generic Event Extension
[    34.696] Initializing built-in extension SHAPE
[    34.696] Initializing built-in extension MIT-SHM
[    34.696] Initializing built-in extension XInputExtension
[    34.696] Initializing built-in extension XTEST
[    34.696] Initializing built-in extension BIG-REQUESTS
[    34.696] Initializing built-in extension SYNC
[    34.696] Initializing built-in extension XKEYBOARD
[    34.696] Initializing built-in extension XC-MISC
[    34.696] Initializing built-in extension XINERAMA
[    34.696] Initializing built-in extension XFIXES
[    34.696] Initializing built-in extension RENDER
[    34.696] Initializing built-in extension RANDR
[    34.696] Initializing built-in extension COMPOSITE
[    34.696] Initializing built-in extension DAMAGE
[    34.696] Initializing built-in extension MIT-SCREEN-SAVER
[    34.696] Initializing built-in extension DOUBLE-BUFFER
[    34.696] Initializing built-in extension RECORD
[    34.696] Initializing built-in extension DPMS
[    34.696] Initializing built-in extension X-Resource
[    34.696] Initializing built-in extension XVideo
[    34.696] Initializing built-in extension XVideo-MotionCompensation
[    34.696] Initializing built-in extension XFree86-VidModeExtension
[    34.696] Initializing built-in extension XFree86-DGA
[    34.696] Initializing built-in extension XFree86-DRI
[    34.696] Initializing built-in extension DRI2
[    34.696] (II) LoadModule: "glx"
[    34.698] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[    34.746] (II) Module glx: vendor="X.Org Foundation"
[    34.746]    compiled for 1.14.7, module version = 1.0.0
[    34.747]    ABI class: X.Org Server Extension, version 7.0
[    34.747] (==) AIGLX enabled
[    34.748] Loading extension GLX
[    34.748] (II) LoadModule: "vesa"
[    34.784] (II) Loading /usr/local/lib/xorg/modules/drivers/vesa_drv.so
[    34.787] (II) Module vesa: vendor="X.Org Foundation"
[    34.787]    compiled for 1.14.7, module version = 2.3.3
[    34.787]    Module class: X.Org Video Driver
[    34.787]    ABI class: X.Org Video Driver, version 14.1
[    34.787] (II) LoadModule: "fbdev"
[    34.814] (WW) Warning, couldn't open module fbdev
[    34.814] (II) UnloadModule: "fbdev"
[    34.814] (II) Unloading fbdev
[    34.814] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    34.814] (II) VESA: driver for VESA chipsets: vesa
[    34.814] (--) Using syscons driver with X support (version 2.0)
[    34.814] (++) using VT number 9

[    34.826] (WW) Falling back to old probe method for vesa
[    34.826] (EE) No devices detected.
[    34.826] (EE)
Fatal server error:
[    34.826] (EE) no screens found(EE)
[    34.826] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    34.826] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    34.826] (EE)
[    34.838] (EE) Server terminated with error (1). Closing log file.



Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Пн 29 июн, 2015 6:06 pm 
Не в сети

Зарегистрирован: Чт 14 май, 2009 6:56 pm
Сообщения: 731
Надо поставить x11/nvidia-driver и x11/nvidia-xconfig. Первое - драйвер, второе - утилита, которая сгенерит годный конфиг иксов сама.

PS. Денис, ты чтоль?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Ср 01 июл, 2015 2:16 pm 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
2 arrowdodger
Здравствуй Глеб ;)
спасибо за советы исполнил их, но счастье не произошло.
Поставил и выдало сие.
Вложение:
IMG_1074.JPG
IMG_1074.JPG [ 473.87 КБ | Просмотров: 9808 ]

Вот новый лог Xorg.0.log: http://paste2.org/cxj1KLBc
Что я делаю не так?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Ср 01 июл, 2015 2:37 pm 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5323
Откуда: СССР, Харьков
Вы драйвер с сайта скачали?
Попробуёте старенький установить. /usr/ports/x11/nvidia-driver-304
И покажите, что в xorg.conf .


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Ср 01 июл, 2015 4:21 pm 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
с сайте не скачивал.
установил так
pkg install x11/nvidia-driver.
Так же его и удалил.
Затем
Код:
# cd /usr/ports/x11/nvidia-driver-304
# make install clean
===> nvidia-driver-304.304.125 requires kernel source files in /usr/src.
*** Error code 1
Stop.
make: stopped in /usr/ports/x11/nvidia-driver-304

Чего-то не хочет?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Ср 01 июл, 2015 4:24 pm 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5323
Откуда: СССР, Харьков
Хочет, но только с исходниками ядра.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Ср 01 июл, 2015 4:27 pm 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
ммм, а если еще раз и чтобы ребенок понял.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Ср 01 июл, 2015 4:32 pm 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5323
Откуда: СССР, Харьков
Как-то так:
viewtopic.php?f=58&t=27368
порт требует наличие исходников ядра, которые прячутся в /usr/src , вам порт об этом написал
Цитата:
===> nvidia-driver-304.304.125 requires kernel source files in /usr/src.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Ср 01 июл, 2015 5:16 pm 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
ankor
Спасибо за инструкцию.

Начал делать вышло
Код:
Tree conflict on '/usr/contrib'
 >local dir unversioned, incoming dir add uppon update

Ну и предлагает выбрать:
    mark resolved
    postpone
    quit resolution


Какой пункт выбрать ?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Ср 01 июл, 2015 6:52 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5087
Откуда: Москва
Похоже что вы качаете исходники в /usr вместо /usr/src


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 9:24 am 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
извините это я ошибся при написании
Tree conflict on '/usr/src/contrib'


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 10:14 am 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
После установки драйвера нвидия выдали сие

Вложение:
ftdtd.JPG
ftdtd.JPG [ 472.82 КБ | Просмотров: 9671 ]

вот конфиг rc.conf
http://paste2.org/mVvKMjZO

в директории /root лежит xorg.conf.new
вот он http://paste2.org/mg56adpU

конфигурация /etc/X11/xorg.conf
http://paste2.org/dwDEwUZW

Что подправить еще?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 10:48 am 
Не в сети

Зарегистрирован: Чт 14 май, 2009 6:56 pm
Сообщения: 731
Полагаю, nvidia не взлетит. Можешь, конечно, погуглить на предмет Nvidia Optimus во фряхе, но это для смелых. А так - попробуй поставить интеловский драйвер x11-drivers/xf86-video-intel и подправить /etc/X11/xorg.conf соответствующим образом.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 12:05 pm 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
arrowdodger писал(а):
Полагаю, nvidia не взлетит.

Спасибо подбодрил :D
Еще мнения будут или это окончательный приговор?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 12:35 pm 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5323
Откуда: СССР, Харьков
Посмотреть вывод: dmesg и pciconf -vl , какое видео видет система.
https://bugs.freebsd.org/bugzilla/show_ ... ?id=192617
Может даже и заведётся.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 12:57 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5087
Откуда: Москва
JSP8 писал(а):
После установки драйвера нвидия выдали сие

Вложение:
ftdtd.JPG

вот конфиг rc.conf
http://paste2.org/mVvKMjZO

в директории /root лежит xorg.conf.new
вот он http://paste2.org/mg56adpU

конфигурация /etc/X11/xorg.conf
http://paste2.org/dwDEwUZW

Что подправить еще?


Погодите. От какой конфигурации был лог Xorg выше? Насколько я помню насчёт оптимуса, основная карта - intel, поэтому на nvidia можно пока забить. У вас есть сгенерированный xorg.conf.new где нормально определилось intel видео. Удалите оттуда ненужные Device (nv и vesa), связанные с ними monitor/screen и измените соответстующим образом ServerLayout, как-то так: http://paste2.org/Lh8OKeht
Это в /etc/X11/xorg.conf и пробовать.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 1:05 pm 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
demesh http://paste2.org/7AA9wNW0
pciconf http://paste2.org/XsmPc8jW

AMDmi3
он остался после того как поставил 304 драйвер из портов и пробовал nvidia-xconfig
сейчас попробую.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 2:06 pm 
Не в сети

Зарегистрирован: Пн 29 июн, 2015 2:31 pm
Сообщения: 12
Аллилуя!
Поднялась графика. Я так понял все заработало на интеловской карте. А можно нвидию запустить?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 2:48 pm 
Не в сети
Site Admin
Аватара пользователя

Зарегистрирован: Вт 10 авг, 2004 2:24 am
Сообщения: 3249
Откуда: Харьков
JSP8 проще всего отключить интел изначально


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Не поднимается Xorg, черный экран
СообщениеДобавлено: Чт 02 июл, 2015 3:31 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5087
Откуда: Москва
JSP8 писал(а):
Поднялась графика. Я так понял все заработало на интеловской карте. А можно нвидию запустить?

В этом и есть основная проблема с оптимусом. Под Linux для переключения на дискретное видео в был/есть проект bumblebee, но чтобы он работал под FreeBSD или были какие-то аналоги я не слышал, хотя стоит погуглить. Либо да, если в BIOS есть какие-то настройки для этого, можно попробовать включить nvidia по умолчанию или отключить интел - тогда должен заработать xorg.conf от nvidia-xconfig.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 23 ]  На страницу 1, 2  След.

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google [Bot], Yahoo [Bot]


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика