BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 9 ] 
Автор Сообщение
СообщениеДобавлено: Чт 23 апр, 2015 11:40 am 
Не в сети
Аватара пользователя

Зарегистрирован: Вс 27 дек, 2009 4:03 pm
Сообщения: 108
Откуда: Воронеж
Добрый день.
Второй раз сталкиваюсь, что актуализация заплаток безопасности портов в FreeBSD сильно опаздывает.
Не хочется собирать из исходников по верх менеджера пакетов.
Раньше такого не было, пол-год назад, все актуально выходило и я даже не задумывался, что такая ситуация может быть.
Вот сижу, жду когда появится обновления php 5.4.40.
В дистрибутивах Linux уже порты обновлены, почему так запаздывает фряха, хз!

_________________
Что бы ты не делал , жизнь слишком коротка!
https://www.fryaha.ru Блог о BSD системах.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 23 апр, 2015 4:24 pm 
Не в сети

Зарегистрирован: Вт 25 апр, 2006 5:31 pm
Сообщения: 890
bagasik писал(а):
Добрый день.
Второй раз сталкиваюсь, что актуализация заплаток безопасности портов в FreeBSD сильно опаздывает.
Не хочется собирать из исходников по верх менеджера пакетов.
Раньше такого не было, пол-год назад, все актуально выходило и я даже не задумывался, что такая ситуация может быть.
Вот сижу, жду когда появится обновления php 5.4.40.
В дистрибутивах Linux уже порты обновлены, почему так запаздывает фряха, хз!

И что Вы ждете?
Код:
 # ls /usr/ports/lang |grep php
php-mode.el
php5
php5-extensions
php55
php55-extensions
php56
php56-extensions
php_doc

# uname -rs
FreeBSD 10.1-RELEASE-p9

Я к тому, что его нет в портах с вытекающими отсюда последствиями.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 23 апр, 2015 4:39 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Вс 27 дек, 2009 4:03 pm
Сообщения: 108
Откуда: Воронеж
GreenDragon писал(а):
bagasik писал(а):
Добрый день.
Второй раз сталкиваюсь, что актуализация заплаток безопасности портов в FreeBSD сильно опаздывает.
Не хочется собирать из исходников по верх менеджера пакетов.
Раньше такого не было, пол-год назад, все актуально выходило и я даже не задумывался, что такая ситуация может быть.
Вот сижу, жду когда появится обновления php 5.4.40.
В дистрибутивах Linux уже порты обновлены, почему так запаздывает фряха, хз!

И что Вы ждете?
Код:
 # ls /usr/ports/lang |grep php
php-mode.el
php5
php5-extensions
php55
php55-extensions
php56
php56-extensions
php_doc

# uname -rs
FreeBSD 10.1-RELEASE-p9

Я к тому, что его нет в портах с вытекающими отсюда последствиями.

Жду когда сформируют порт с заплатками.

_________________
Что бы ты не делал , жизнь слишком коротка!
https://www.fryaha.ru Блог о BSD системах.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 23 апр, 2015 8:27 pm 
Не в сети

Зарегистрирован: Ср 14 окт, 2009 2:26 pm
Сообщения: 587
bagasik писал(а):
Жду когда сформируют порт с заплатками.

GreenDragon пытался Вам подсказать, что php54 уже не поддерживается. (ну типа, чтобы Вы зря не ждали)
/usr/ports/UPDATING писал(а):
20150220:
AFFECTS: users of PHP

The default PHP version has been updated from 5.4 to 5.6.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 23 апр, 2015 8:50 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Вс 27 дек, 2009 4:03 pm
Сообщения: 108
Откуда: Воронеж
xemul писал(а):
bagasik писал(а):
Жду когда сформируют порт с заплатками.

GreenDragon пытался Вам подсказать, что php54 уже не поддерживается. (ну типа, чтобы Вы зря не ждали)
/usr/ports/UPDATING писал(а):
20150220:
AFFECTS: users of PHP

The default PHP version has been updated from 5.4 to 5.6.

Не понял.
Сегодня обновлял порты.
Код:
root@148:/usr/ports/lang/php5 # cd /usr/ports/lang/php5/ && make showconfig | grep configur
===> The following configuration options are available for php5-5.4.39:

Что значит не поддерживается, оффициально ветка php 5.4 рабоча и поддерживается.
Сейчас посомтрел, обновлений нет и к веткам php 5.6, и ветки 5.5.
Раньше такого небыло, что заплатки формируются в портах по несколько недель.
Из-за этого приходится либо отключать функционал либо переходить на оффициальные исходники.
http://php.net/ChangeLog-5.php#5.4.40

_________________
Что бы ты не делал , жизнь слишком коротка!
https://www.fryaha.ru Блог о BSD системах.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 23 апр, 2015 9:44 pm 
Не в сети

Зарегистрирован: Ср 14 окт, 2009 2:26 pm
Сообщения: 587
bagasik писал(а):
Не понял.
Сегодня обновлял порты.

Выполните `ls /usr/ports/lang |grep php` (хотя это уже было сделано за Вас, и выхлоп приведён) и найдите в выхлопе упоминание про php54.
Цитата:
Что значит не поддерживается, оффициально ветка php 5.4 рабоча и поддерживается.

Не поддерживается в портах/пакетах FreeBSD.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 23 апр, 2015 10:22 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5195
Откуда: Москва
xemul писал(а):
Выполните `ls /usr/ports/lang |grep php` (хотя это уже было сделано за Вас, и выхлоп приведён) и найдите в выхлопе упоминание про php54.

Код:
% ls /usr/ports/lang |grep php
php-mode.el
php5                           <- вот оно
php5-extensions
php55
php55-extensions
php56
php56-extensions
php_doc

Не надо вводить в заблуждение людей. php 5.4 поддерживается, и обновление действительно запаздывает.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пт 24 апр, 2015 11:26 am 
Не в сети

Зарегистрирован: Ср 14 окт, 2009 2:26 pm
Сообщения: 587
AMDmi3 писал(а):
Код:
% ls /usr/ports/lang |grep php
php-mode.el
php5                           <- вот оно
php5-extensions
php55
php55-extensions
php56
php56-extensions
php_doc

И точно ведь, уже на это наступал - по `pkg install lang/php` пытался поставиться совсем не дефолтный php54, - но забыл.
Цитата:
Не надо вводить в заблуждение людей. php 5.4 поддерживается, и обновление действительно запаздывает.

Виноват, исправлюсь.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пн 27 апр, 2015 9:56 am 
Не в сети

Зарегистрирован: Вт 25 апр, 2006 5:31 pm
Сообщения: 890
хех, действительно
Код:
 grep -i "PORTVERSION=" /usr/ports/lang/php5/Makefile
PORTVERSION=    5.4.39

но почему-то всегда считал что в php5 находится экспериментальная версия
Сорь, за введение в заблуждение


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 9 ] 

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: нет зарегистрированных пользователей


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика