BSDPORTAL.RU
http://bsdportal.ru/

Видеокарта nvidia в 11.0-CURRENT
http://bsdportal.ru/viewtopic.php?f=25&t=27585
Страница 1 из 1

Автор:  varahi [ Чт 12 ноя, 2015 7:40 am ]
Заголовок сообщения:  Видеокарта nvidia в 11.0-CURRENT

Доброго дня всем.
Ради установки скайпа, я обновил систему с 10.2 до FreeBSD 11.0-CURRENT. Обновление делал так
Код:
> svnlite co http://svn.freebsd.org/base/head
> cd head
> su root
> make buildworld buildkernel installkernel installworld && reboot

http://slice2.com/2015/02/10/howto-upda ... t-release/

Все хорошо, и даже скайп завелся, но не работают драйвера для видео карты Nvidia. при попытке установить драйвер пишет
Код:
root@t3dev:/home/dima/Distr/NVIDIA-FreeBSD-x86-340.93 # make
===> src (all)
make[1]: "/sys/conf/kern.mk" line 43: Malformed conditional (${MK_FORMAT_EXTENSIONS} == "no")
make[1]: Fatal errors encountered -- cannot continue
make[1]: stopped in /usr/home/dima/Distr/NVIDIA-FreeBSD-x86-340.93/src
*** Error code 1

Если попробовать загрузить старый модуль kldload nvidia
Код:
kldload: can't load nvidia: module already loaded or in kernel

Разве это правильно, разве должен он быть в ядре?
Дурацкий вопрос, но все-таки: может быть так, что модуль уже загружен в ядро из-за того, что я собирал с загруженым модулем nvidia (через kldload) и при сборке не указал buildkernel KERNCONF=GENERIC?
Подскажите, как мне завести драйвер для nvidia в 11.0-CURRENT?

З.Ы. Скайп завелся не сразу, помогло вот это https://groups.google.com/forum/#!topic ... z21DUvbPsU

Автор:  ankor [ Чт 12 ноя, 2015 9:32 am ]
Заголовок сообщения:  Re: Видеокарта nvidia в 11.0-CURRENT

Установить из портов не пробовали?

Автор:  varahi [ Чт 12 ноя, 2015 1:38 pm ]
Заголовок сообщения:  Re: Видеокарта nvidia в 11.0-CURRENT

Из портов выглядит так
Цитата:
stopped in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86-346.96
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Пробую сделать так
Цитата:
root@t3dev:/usr/ports/x11/nvidia-driver # make MAKE_JOBS_UNSAFE=yes
pkg-static: Warning: Major OS version upgrade detected. Running "pkg-static install -f pkg" recommended


Далее пробую сделать это
Цитата:
root@t3dev:/home/dima # pkg-static install -f pkg
pkg-static: Warning: Major OS version upgrade detected. Running "pkg-static install -f pkg" recommended
Updating FreeBSD repository catalogue...
Repository FreeBSD has a wrong packagesite, need to re-create database
pkg-static: http://pkg.FreeBSD.org/FreeBSD:11:i386/ ... y/meta.txz: Not Found
repository FreeBSD has no meta file, using default settings
pkg-static: http://pkg.FreeBSD.org/FreeBSD:11:i386/ ... gesite.txz: Not Found
Unable to update repository FreeBSD

Возниакет еще один вопрос: как заменить путь? http://pkg.FreeBSD.org/FreeBSD:11:i386/ ... y/meta.txz на http://pkg.freebsd.org/freebsd:11:x86:3 ... t/meta.txz и нужно ли делать pkg-static?

Автор:  AMDmi3 [ Чт 12 ноя, 2015 1:46 pm ]
Заголовок сообщения:  Re: Видеокарта nvidia в 11.0-CURRENT

Путь задаётся в /etc/pkg/FreeBSD.conf. И он должен быть правильным, если вы не забыли сделать mergemaster. Только если уж ставите из портов, то и pkg обновляйте из портов.

Автор:  arrowdodger [ Чт 12 ноя, 2015 8:50 pm ]
Заголовок сообщения:  Re: Видеокарта nvidia в 11.0-CURRENT

Цитата:
Из портов выглядит так

Ошибка осталась в логе сверху, вы ее не показали.

Автор:  AlexVPetrov [ Чт 12 ноя, 2015 11:14 pm ]
Заголовок сообщения:  Re: Видеокарта nvidia в 11.0-CURRENT

varahi писал(а):
Ради установки скайпа, я обновил систему с 10.2 до FreeBSD 11.0-CURRENT. Обновление делал так

mergemaster делали?
delete-old delete-old-libs делали?
Порты/пакеты после перехода на новую систему обновляли? Как?

Автор:  varahi [ Пт 13 ноя, 2015 8:46 pm ]
Заголовок сообщения:  Re: Видеокарта nvidia в 11.0-CURRENT

delete-old delete-old-libs не делал. И скорее всего, что-то не совсем корректно сделал до этого (я давно не пользовался freebsd, хочу перейти на неё) .
Обновил все порты и пакеты. Переустановил пакеты xorg, kde и весь xf86*, драйвер для nvidia установился тоже только из пакетов. Пересобрал скайп. Модуль nvidia нормально подгружается.
В общем всё заработало, тема закрыта. Всем спасибо.

Страница 1 из 1 Часовой пояс: UTC + 4 часа
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/