BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 3 ] 
Автор Сообщение
 Заголовок сообщения: Понизить версию pkg.
СообщениеДобавлено: Вт 28 авг, 2018 5:19 pm 
Не в сети

Зарегистрирован: Вт 28 авг, 2018 5:07 pm
Сообщения: 2
По невнимательности на freebsd 10.1 обновил pgk 1.6.1 на 1.10.5
После чего перестало работать одно из расширении php.

ошибка.
Shared object "libpkg.so.3" not found, required by "snmp.so" in Unknown on line 0

файла такого нету есть только libpkg.so.4
возможно ли сделать откат до предыдущий версии??


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Понизить версию pkg.
СообщениеДобавлено: Вт 28 авг, 2018 7:44 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5190
Откуда: Москва
Предполагаю что libpkg для php-snmp не нужен ну вообще никак, и добавляется из-за кривой сборки php.
Соответственно починить можно как угодно, вплоть до сделать симлинк libpkg.so.3 → libpkg.so.4, всё равно библиотека не используется.
Можно просто пересобрать модуль чтобы он подхватил новую библиотеку.

https://bugs.freebsd.org/bugzilla/show_ ... ?id=230980


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Понизить версию pkg.
СообщениеДобавлено: Вт 28 авг, 2018 10:42 pm 
Не в сети

Зарегистрирован: Вт 28 авг, 2018 5:07 pm
Сообщения: 2
AMDmi3 писал(а):
Предполагаю что libpkg для php-snmp не нужен ну вообще никак, и добавляется из-за кривой сборки php.
Соответственно починить можно как угодно, вплоть до сделать симлинк libpkg.so.3 → libpkg.so.4, всё равно библиотека не используется.
Можно просто пересобрать модуль чтобы он подхватил новую библиотеку.

https://bugs.freebsd.org/bugzilla/show_ ... ?id=230980


Огромный респект))
#cd /usr/local/lib
#ln -s libpkg.so.4 libpkg.so.3

все заработало)


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 3 ] 

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google Feedfetcher


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика