BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 8 ] 
Автор Сообщение
 Заголовок сообщения: FreeBSD 11.0-CURRENT linuxator64
СообщениеДобавлено: Пн 25 май, 2015 7:01 pm 
Не в сети

Зарегистрирован: Вс 05 июн, 2005 4:19 pm
Сообщения: 3072
Откуда: Ukraine
Собстеввно говоря и вся новость - проверяйте что у кого отвалилось при этом.

_________________
Ми можемо все - що здатні собі уявити!
uname -a
Linux nonamehost 4.10.2-zen-fidaj-muqss-ck+ #4 ZEN SMP PREEMPT Sun Mar 12 19:48:08 EET 2017 x86_64 x86_64 x86_64 GNU/Linux


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: FreeBSD 11.0-CURRENT linuxator64
СообщениеДобавлено: Вт 16 июн, 2015 11:49 pm 
Не в сети

Зарегистрирован: Вт 08 июл, 2014 4:06 pm
Сообщения: 130
А где ядро х64 от CentOS найти и как впихнуть то?)

Собственно как впихнуть обычно знаю. КОгда-то нашёл этот материальчик, спасибо автору
https://cooltrainer.org/a-freebsd-deskt ... inuxulator
ПРосто вопрос в том плане, автоматом установит х64 если стоит amd64 или это надо должным образом указать.


Последний раз редактировалось korino Вт 16 июн, 2015 11:54 pm, всего редактировалось 1 раз.

Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: FreeBSD 11.0-CURRENT linuxator64
СообщениеДобавлено: Ср 17 июн, 2015 1:03 am 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5081
Откуда: Москва
korino писал(а):
А где ядро х64 от CentOS найти и как впихнуть то?)

Для работы linuxulator не нужно ядро linux.

korino писал(а):
ПРосто вопрос в том плане, автоматом установит х64 если стоит amd64 или это надо должным образом указать.

В портах 64-битных linux пакетов пока нет.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: FreeBSD 11.0-CURRENT linuxator64
СообщениеДобавлено: Вт 07 июл, 2015 2:05 pm 
Не в сети

Зарегистрирован: Вт 08 июл, 2014 4:06 pm
Сообщения: 130
"Для работы linuxulator не нужно ядро linux."

Извиняюсь за нубский вопрос. Но ведь версию 2.6.18 закачивает же. Видно как идёт загрузка. ( в портах,после выбора цента)
А если не указать принудительно 2.6.18, то ругался, что надо более новую указать.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: FreeBSD 11.0-CURRENT linuxator64
СообщениеДобавлено: Вт 07 июл, 2015 2:14 pm 
Не в сети

Зарегистрирован: Вс 05 июн, 2005 4:19 pm
Сообщения: 3072
Откуда: Ukraine
korino писал(а):
"Для работы linuxulator не нужно ядро linux."

Извиняюсь за нубский вопрос. Но ведь версию 2.6.18 закачивает же. Видно как идёт загрузка. ( в портах,после выбора цента)
А если не указать принудительно 2.6.18, то ругался, что надо более новую указать.

Причём тут порты?
В портах всякое линукс окружение, а в ядерном модуле "ретранслятор" линуксовых системных вызовов.
Это разные вещи.
Никакого линукс ядра не закачивается при этом.

_________________
Ми можемо все - що здатні собі уявити!
uname -a
Linux nonamehost 4.10.2-zen-fidaj-muqss-ck+ #4 ZEN SMP PREEMPT Sun Mar 12 19:48:08 EET 2017 x86_64 x86_64 x86_64 GNU/Linux


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: FreeBSD 11.0-CURRENT linuxator64
СообщениеДобавлено: Вт 07 июл, 2015 2:19 pm 
Не в сети

Зарегистрирован: Вт 08 июл, 2014 4:06 pm
Сообщения: 130
Я об этом
когда пишем compat.linux.osrelease=2.6.18 в /etc/sysctl.conf то видно же что потом идёт закачка. После указания установки в портах с выбором цента.( ну а если не указать, то будет ругань с требованием изменить на 2.6.18)
Это не ядро,а "ретранслятор"? ( объёмный он, думал что ядро :( )
Спасибо за разъяснение моего заблуждения.
ВОт только 1 не понимаю, написано в https://cooltrainer.org/a-freebsd-deskt ... inuxulator следующее tell your system to load the linux kernel module at boot.
Где мой косяк в понимании?


Последний раз редактировалось korino Вт 07 июл, 2015 2:33 pm, всего редактировалось 1 раз.

Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: FreeBSD 11.0-CURRENT linuxator64
СообщениеДобавлено: Вт 07 июл, 2015 2:29 pm 
Не в сети

Зарегистрирован: Вс 05 июн, 2005 4:19 pm
Сообщения: 3072
Откуда: Ukraine
korino писал(а):
Я об этом
когда пишем compat.linux.osrelease=2.6.18 в /etc/sysctl.conf то видно же что потом идёт закачка. После указания установки в портах с выбором цента.( ну а если не указать, то будет ругань с требованием изменить на 2.6.18)
Это не ядро,а "ретранслятор"? ( объёмный он, думал что ядро :( )
Спасибо за разъяснение моего заблуждения.

"Ретранслятор" - это /boot/kernel/linux64.ko и /boot/kernel/linux.ko
"то что при этом идет закачка" - это тянется портовое окружение.
смысла вписывать compat.linux.osrelease=2.6.18 нет никакого ибо уже compat.linux.osrelease: 2.6.32

_________________
Ми можемо все - що здатні собі уявити!
uname -a
Linux nonamehost 4.10.2-zen-fidaj-muqss-ck+ #4 ZEN SMP PREEMPT Sun Mar 12 19:48:08 EET 2017 x86_64 x86_64 x86_64 GNU/Linux


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: FreeBSD 11.0-CURRENT linuxator64
СообщениеДобавлено: Пн 14 дек, 2015 12:30 am 
Не в сети

Зарегистрирован: Пт 16 авг, 2013 11:47 pm
Сообщения: 28
У меня filezilla перестала работать
Код:
(process:3104): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(process:3104): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
(process:3104): Gtk-CRITICAL **: IA__gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(process:3104): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
(process:3104): Gtk-CRITICAL **: IA__gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(process:3104): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
(process:3104): Gtk-CRITICAL **: IA__gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(process:3104): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
(process:3104): Gtk-CRITICAL **: IA__gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(process:3104): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
(process:3104): GLib-GObject-WARNING **: value "TRUE" of type 'gboolean' is invalid or out of range for property 'visible' of type 'gboolean'
(process:3104): Gtk-CRITICAL **: IA__gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(process:3104): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
(process:3104): Gtk-CRITICAL **: IA__gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(process:3104): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
(process:3104): Gtk-CRITICAL **: IA__gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(process:3104): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
(process:3104): GLib-GObject-WARNING **: value "TRUE" of type 'gboolean' is invalid or out of range for property 'visible' of type 'gboolean'
(process:3104): Gtk-CRITICAL **: IA__gtk_settings_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(process:3104): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
(process:3104): Gtk-WARNING **: Screen for GtkWindow not set; you must always set
a screen for a GtkWindow before using the window
(process:3104): Gdk-CRITICAL **: IA__gdk_pango_context_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
...............................................................................
(process:3104): Gdk-CRITICAL **: IA__gdk_window_new: assertion 'GDK_IS_WINDOW (parent)' failed
Ошибка сегментации(core dumped)


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 8 ] 

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google [Bot], Vit., Yahoo [Bot]


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика