BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 2 ] 
Автор Сообщение
СообщениеДобавлено: Сб 03 апр, 2021 4:50 pm 
Не в сети

Зарегистрирован: Сб 03 апр, 2021 4:35 pm
Сообщения: 1
Добрый день, уважаемые форумчане.
Есть сервер с FreeBSD 11.2-RELEASE-p14
На сервер была установлена СУБД Postgres 9.5 с расширением PostGIS 2.4. Во время обновления другого пакета с помощью pkg это расширение по незнанию было также обновлено вместе с Postgres. База на новом Postgres работала некорректно и было решено установить версию 9.5, но вот PostGIS 2.4 уже не устанавливается на эту версию и требует версию Postgres минимум 12.
Сейчас база данных вроде бы работает, но при попытке сделать бекап вываливается это.

Код:
sudo pg_dumpall > 1.psql
pg_dump: error: Dumping the contents of table "zip_code" failed: PQgetResult() failed.
pg_dump: error: Error message from server: ERROR:  could not access file "$libdir/postgis-2.4": No such file or directory
pg_dump: error: The command was: COPY public.zip_code (id, code, area) TO stdout;


Как установить PostGIS 2.4, не удаляя Postgres 9.5, чтобы сделать хотя бы полноценный бекап.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Вс 04 апр, 2021 4:23 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5337
Откуда: Москва
Вероятно откатывать дерево портов на тот момент когда всё было установлено и ставить из него postgis.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 2 ] 

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot]


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика