BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 30 ]  На страницу Пред.  1, 2
Автор Сообщение
СообщениеДобавлено: Ср 25 янв, 2017 8:16 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5237
Откуда: Москва
Elimelech писал(а):
дайте знать, когда заработает. А пакеты тоже вы чините?

Исправление в портах. Пакеты чинятся сами потому что собираются из портов.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 25 янв, 2017 9:37 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Вт 07 май, 2013 8:43 pm
Сообщения: 827
Откуда: Украина
AlexVPetrov писал(а):
а
Код:
printenv PATH
что покажет?


Код:
root@A9t:/home/luba # printenv PATH
/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin

_________________
FreeBSD A9t 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC i386


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 25 янв, 2017 9:50 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Вт 07 май, 2013 8:43 pm
Сообщения: 827
Откуда: Украина
AMDmi3 писал(а):
Elimelech писал(а):
дайте знать, когда заработает. А пакеты тоже вы чините?

Исправление в портах. Пакеты чинятся сами потому что собираются из портов.

И это вы называете починили:
Код:
root@A9t:/usr/ports/multimedia/pitivi # make install clean
===>  pitivi-0.13.4.2_4 has known vulnerabilities:
pitivi-0.13.4.2_4 is vulnerable:
pitivi -- code execution
CVE: CVE-2015-0855
WWW: https://vuxml.FreeBSD.org/freebsd/6540c8f0-dca3-11e5-8fa8-14dae9d210b8.html

1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make: stopped in /usr/ports/multimedia/pitivi
root@A9t:/usr/ports/multimedia/pitivi #

_________________
FreeBSD A9t 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC i386


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 25 янв, 2017 10:14 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5237
Откуда: Москва
Это несвязанные проблемы.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 25 янв, 2017 10:24 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Вт 07 май, 2013 8:43 pm
Сообщения: 827
Откуда: Украина
AMDmi3 писал(а):
Это несвязанные проблемы.

вот именно проблемы. :(

_________________
FreeBSD A9t 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC i386


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 26 янв, 2017 10:42 am 
Не в сети

Зарегистрирован: Пн 02 фев, 2009 12:54 pm
Сообщения: 482
Elimelech писал(а):
вот именно проблемы. :(


А что мешает вписать DISABLE_VULNERABILITIES=yes в /etc/make.conf?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 26 янв, 2017 11:43 am 
Не в сети
Аватара пользователя

Зарегистрирован: Вт 07 май, 2013 8:43 pm
Сообщения: 827
Откуда: Украина
fsx писал(а):
Elimelech писал(а):
вот именно проблемы. :(


А что мешает вписать DISABLE_VULNERABILITIES=yes в /etc/make.conf?

и что тады будет? УЯЗВИМЫЕ не хочется ставить.:)))

_________________
FreeBSD A9t 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC i386


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 26 янв, 2017 12:03 pm 
Не в сети

Зарегистрирован: Ср 14 окт, 2009 2:26 pm
Сообщения: 589
fsx писал(а):
А что мешает вписать DISABLE_VULNERABILITIES=yes в /etc/make.conf?

Вредный совет. 'make DISABLE_VULNERABILITIES=yes' для отдельно взятого порта, без которого ну никак, безопаснее.
Elimelech писал(а):
вот именно проблемы. :(

Вас не смущает версия порта 0.13.4.2_4 при текущей версии на pitivi.org 0.97? Или Вы на pitivi.org не заглядывали?
Цитата:
и что тады будет? УЯЗВИМЫЕ не хочется ставить.

Сделайте порт текущей версии с исправленной уязвимостью.
(Вы хоть посмотрели, что там за беда? При работе с файлами на локальном компе она и не беда. Но вот 0.13 против 0.97 - это беда.)


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 26 янв, 2017 12:08 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Вт 07 май, 2013 8:43 pm
Сообщения: 827
Откуда: Украина
xemul писал(а):
Сделайте порт текущей версии с исправленной уязвимостью.
(Вы хоть посмотрели, что там за беда? При работе с файлами на локальном компе она и не беда. Но вот 0.13 против 0.97 - это беда.)

я не умею делать порты. :)))

_________________
FreeBSD A9t 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC i386


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 26 янв, 2017 1:49 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Вт 07 май, 2013 8:43 pm
Сообщения: 827
Откуда: Украина
Pitivi 0.98 — Getting there.

_________________
FreeBSD A9t 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC i386


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 30 ]  На страницу Пред.  1, 2

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google [Bot], Google Feedfetcher


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика