BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 14 ] 
Автор Сообщение
 Заголовок сообщения: Сборке virtualbos-ose - XML::Parser... configure err
СообщениеДобавлено: Вс 03 ноя, 2013 1:14 pm 
Не в сети

Зарегистрирован: Вт 29 окт, 2013 12:42 pm
Сообщения: 19
Никак не могу собрать virtualbos-ose из портов.
Возникает ошибка на стадии сборки dconf:
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

Дано, freebsd 9.2, kde4, linux_base-f10
1) пробовал virtualbos-ose-legacy, ошибка таже;
2) с помощью portupgrade обновил все, что касается perl, от чего он зависит и что от него
3) пересборка kde и perl не помогает.

Вот лог сборки
$ cd /usr/ports/emulators/virtualbox-ose
$ sudo make install >> /var/log/virtual-ose.log
cannot create /var/log/virtual-ose.log: Permission denied
$ sudo make install >> /usr/ports/emulators/virtualbox-ose/virtual-ose.log
cannot create /usr/ports/emulators/virtualbox-ose/virtual-ose.log: Permission de nied
$ sudo make install >> virtual-ose.log
cannot create virtual-ose.log: Permission denied
$ sudo make install
===> virtualbox-ose-4.2.18_1 depends on executable: yasm - found
===> virtualbox-ose-4.2.18_1 depends on executable: as86 - found
===> virtualbox-ose-4.2.18_1 depends on executable: xsltproc - found
===> virtualbox-ose-4.2.18_1 depends on executable: kmk - found
===> virtualbox-ose-4.2.18_1 depends on executable: gtar - found
===> virtualbox-ose-4.2.18_1 depends on executable: cdrecord - found
===> virtualbox-ose-4.2.18_1 depends on file: /usr/local/bin/easy_install-2.7 - found
===> virtualbox-ose-4.2.18_1 depends on file: /usr/local/bin/python2.7 - found
===> virtualbox-ose-4.2.18_1 depends on executable: python - found
===> virtualbox-ose-4.2.18_1 depends on executable: pkgconf - found
===> virtualbox-ose-4.2.18_1 depends on file: /usr/local/libdata/pkgconfig/inp utproto.pc - found
===> virtualbox-ose-4.2.18_1 depends on file: /usr/local/libdata/pkgconfig/xcu rsor.pc - found
===> virtualbox-ose-4.2.18_1 depends on file: /usr/local/libdata/pkgconfig/xmu .pc - found
===> virtualbox-ose-4.2.18_1 depends on file: /usr/local/libdata/pkgconfig/xin erama.pc - found
===> virtualbox-ose-4.2.18_1 depends on file: /usr/local/bin/sdl-config - not found
===> Verifying install for /usr/local/bin/sdl-config in /usr/ports/devel/sdl1 2
===> sdl-1.2.15_2,2 depends on executable: nasm - found
===> sdl-1.2.15_2,2 depends on executable: pkgconf - found
===> sdl-1.2.15_2,2 depends on executable: gmake - found
===> sdl-1.2.15_2,2 depends on file: /usr/local/libdata/pkgconfig/xextproto.pc - found
===> sdl-1.2.15_2,2 depends on file: /usr/local/libdata/pkgconfig/glproto.pc - found
===> sdl-1.2.15_2,2 depends on file: /usr/local/libdata/pkgconfig/dri2proto.pc - found
===> sdl-1.2.15_2,2 depends on file: /usr/local/libdata/pkgconfig/x11.pc - fou nd
===> sdl-1.2.15_2,2 depends on file: /usr/local/libdata/pkgconfig/xrender.pc - found
===> sdl-1.2.15_2,2 depends on file: /usr/local/libdata/pkgconfig/xrandr.pc - found
===> sdl-1.2.15_2,2 depends on package: libtool>=2.4 - found
===> sdl-1.2.15_2,2 depends on shared library: libiconv.so.3 - found
- found
===> sdl-1.2.15_2,2 depends on shared library: libGLU.so - found
- found
===> sdl-1.2.15_2,2 depends on shared library: aa - found
===> sdl-1.2.15_2,2 depends on shared library: ggi - found
===> sdl-1.2.15_2,2 depends on shared library: audio - found
===> sdl-1.2.15_2,2 depends on shared library: pulse-simple - not found
===> Verifying install for pulse-simple in /usr/ports/audio/pulseaudio
===> pulseaudio-0.9.23_2 depends on executable: gmake - found
===> pulseaudio-0.9.23_2 depends on executable: pkgconf - found
===> pulseaudio-0.9.23_2 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===> pulseaudio-0.9.23_2 depends on file: /usr/local/libdata/pkgconfig/sm.pc - found
===> pulseaudio-0.9.23_2 depends on file: /usr/local/libdata/pkgconfig/xtst.pc - found
===> pulseaudio-0.9.23_2 depends on file: /usr/local/libdata/pkgconfig/ice.pc - found
===> pulseaudio-0.9.23_2 depends on package: libtool>=2.4 - found
===> pulseaudio-0.9.23_2 depends on file: /usr/local/bin/intltool-extract - fo und
===> pulseaudio-0.9.23_2 depends on shared library: libintl.so - found
- found
===> pulseaudio-0.9.23_2 depends on shared library: samplerate.1 - found
===> pulseaudio-0.9.23_2 depends on shared library: sndfile.1 - found
===> pulseaudio-0.9.23_2 depends on shared library: speexdsp.1 - found
===> pulseaudio-0.9.23_2 depends on shared library: dbus-1.3 - found
===> pulseaudio-0.9.23_2 depends on shared library: gdbm.4 - found
===> pulseaudio-0.9.23_2 depends on shared library: execinfo - found
===> pulseaudio-0.9.23_2 depends on shared library: ck-connector.0 - found
===> pulseaudio-0.9.23_2 depends on shared library: avahi-client.3 - found
===> pulseaudio-0.9.23_2 depends on shared library: hal.1 - found
===> pulseaudio-0.9.23_2 depends on shared library: ltdl.7 - found
===> pulseaudio-0.9.23_2 depends on shared library: atk-1.0 - found
===> pulseaudio-0.9.23_2 depends on shared library: gconf-2.4 - not found
===> Verifying install for gconf-2.4 in /usr/ports/devel/gconf2
===> gconf2-2.32.0_3 depends on executable: gmake - found
===> gconf2-2.32.0_3 depends on executable: pkgconf - found
===> gconf2-2.32.0_3 depends on package: libtool>=2.4 - found
===> gconf2-2.32.0_3 depends on file: /usr/local/bin/intltool-extract - found
===> gconf2-2.32.0_3 depends on shared library: libintl.so - found
- found
===> gconf2-2.32.0_3 depends on shared library: dbus-glib-1 - found
===> gconf2-2.32.0_3 depends on shared library: polkit-gobject-1 - found
===> gconf2-2.32.0_3 depends on shared library: atk-1.0 - found
===> gconf2-2.32.0_3 depends on shared library: dconf - not found
===> Verifying install for dconf in /usr/ports/devel/dconf
===> dconf-0.14.1 depends on package: vala>=0.18.1 - found
===> dconf-0.14.1 depends on package: docbook-xsl>=0 - found
===> dconf-0.14.1 depends on executable: gmake - found
===> dconf-0.14.1 depends on executable: pkgconf - found
===> dconf-0.14.1 depends on file: /usr/local/bin/intltool-extract - found
===> dconf-0.14.1 depends on shared library: libdbus-1.so - found
- found
===> dconf-0.14.1 depends on shared library: libintl.so - found
- found
===> dconf-0.14.1 depends on shared library: glib-2.0 - found
===> dconf-0.14.1 depends on shared library: pcre - found
===> Configuring for dconf-0.14.1
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking whether gmake supports nested variables... yes
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking for style of include used by gmake... GNU
checking dependency style of cc... gcc3
checking for valac... /usr/local/bin/valac
checking /usr/local/bin/valac is at least version 0.17.0... yes
checking for ranlib... ranlib
checking for xsltproc... /usr/local/bin/xsltproc
checking pkg-config is at least version 0.16... yes
checking for gtkdoc-check... no
checking for gtkdoc-rebase... no
checking for gtkdoc-mkpdf... no
checking whether to build gtk-doc documentation... no
checking for glib... yes
checking for gio... yes
checking for dbus... yes
checking for gio-querymodules... /usr/local/bin/gio-querymodules
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... no
checking for bindtextdomain in -lintl... yes
checking for ngettext in -lintl... yes
checking for dgettext in -lintl... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... /usr/local/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... /usr/local/bin/msgfmt
checking for xgettext... /usr/local/bin/xgettext
checking whether NLS is requested... yes
checking for intltool >= 0.50.0... 0.50.2 found
checking for intltool-update... /usr/local/bin/intltool-update
checking for intltool-merge... /usr/local/bin/intltool-merge
checking for intltool-extract... /usr/local/bin/intltool-extract
checking for xgettext... (cached) /usr/local/bin/xgettext
checking for msgmerge... /usr/local/bin/msgmerge
checking for msgfmt... (cached) /usr/local/bin/msgfmt
checking for gmsgfmt... (cached) /usr/local/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.14.4
checking for XML::Parser... configure: error: XML::Parser perl module is require d for intltool
===> Script "configure" failed unexpectedly.
Please run the gnomelogalyzer, available from
"http://www.freebsd.org/gnome/gnomelogalyzer.sh", which will diagnose the
problem and suggest a solution. If - and only if - the gnomelogalyzer cannot
solve the problem, report the build failure to the FreeBSD GNOME team at
gnome@FreeBSD.org, and attach (a)
"/usr/ports/devel/dconf/work/dconf-0.14.1/config.log", (b) the output of the
failed make command, and (c) the gnomelogalyzer output. Also, it might be a
good idea to provide an overview of all packages installed on your system
(i.e. an `ls /var/db/pkg`). Put your attachment up on any website,
copy-and-paste into http://freebsd-gnome.pastebin.com, or use send-pr(1) with
the attachment. Try to avoid sending any attachments to the mailing list
(gnome@FreeBSD.org), because attachments sent to FreeBSD mailing lists are
usually discarded by the mailing list software.
*** [do-configure] Error code 1

Stop in /usr/ports/devel/dconf.
*** [lib-depends] Error code 1

Stop in /usr/ports/devel/gconf2.
*** [install] Error code 1

Stop in /usr/ports/devel/gconf2.
*** [lib-depends] Error code 1

Stop in /usr/ports/audio/pulseaudio.
*** [install] Error code 1

Stop in /usr/ports/audio/pulseaudio.
*** [lib-depends] Error code 1

Stop in /usr/ports/devel/sdl12.
*** [install] Error code 1

Stop in /usr/ports/devel/sdl12.
*** [build-depends] Error code 1

Stop in /usr/ports/emulators/virtualbox-ose.
*** [install] Error code 1

Stop in /usr/ports/emulators/virtualbox-ose.
$ mc


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Вс 03 ноя, 2013 2:01 pm 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5334
Откуда: СССР, Харьков
Вам надо переустановить.
/usr/ports/textproc/p5-XML-Parser
и глянуть в /usr/ports/UPDATING


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Вс 03 ноя, 2013 2:32 pm 
Не в сети

Зарегистрирован: Вт 29 окт, 2013 12:42 pm
Сообщения: 19
Спасибо,
Вообще-то я сделал это первым делом, но это было давно, до всех других действий, попробую,
переустановить, смотрю что будет дальше.

вот до кучи...

$ perl5 -e "require XML::Parser"
Can't locate XML/Parser.pm in @INC (@INC contains: /usr/local/lib/perl5/5.14/BSDPAN /usr/local/lib/perl5/site_perl/5.14/mach /usr/local/lib/perl5/site_perl/5.14 /usr/local/lib/perl5/5.14/mach /usr/local/lib/perl5/5.14 .) at -e line 1.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 07 ноя, 2013 7:09 am 
Не в сети
Аватара пользователя

Зарегистрирован: Пт 09 апр, 2010 9:49 pm
Сообщения: 565
Откуда: большой деревни
Код:
ls /usr/local/lib/perl5/site-perl/5.14/mach/XML/Parser.pm

Код:
pkg_info -xL p5-XML-Parser

что говорит первое и второе

_________________
никто кроме нас (С)
пять строчек лога могут дать больше информации, чем тысяча строк описания, что и как не работает.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пт 08 ноя, 2013 1:39 am 
Не в сети

Зарегистрирован: Вс 05 июн, 2005 4:19 pm
Сообщения: 3073
Откуда: Ukraine
судя по версии virtualbox - порты довольно свежие...
сейчас дефолтный perl это 5.16
прочтите внимательно /usr/ports/UPDATING на предмет 20131023:
и произведите указанные там действия
Код:
  The default perl has been switched to lang/perl5.16. If you're using binary
  packages, you need to do :

  # pkg set -o lang/perl5.14:lang/perl5.16

  If you're not using binary packages and want to (and should) switch, if
  you're using perl-5.14, for instance :

  Portupgrade users:
    0) Fix pkgdb.db (for safety):
        pkgdb -Ff

    1) Reinstall new version of Perl (5.16):
        portupgrade -o lang/perl5.16 -f perl-5.14.\*

    2) Reinstall everything that depends on Perl:
        portupgrade -fr perl

  Portmaster users:
        portmaster -o lang/perl5.16 lang/perl5.14

        Conservative:
        portmaster p5-

        Comprehensive (but perhaps overkill):
        portmaster -r perl-

  Note: If the "perl-" glob matches more than one port you will need to specify
        the name of the Perl directory in /var/db/pkg explicitly.


должно помочь...

_________________
Ми можемо все - що здатні собі уявити!
uname -a
Linux nonamehost 4.12.12-zen+ #5 ZEN SMP Thu Sep 14 08:50:28 EEST 2017 x86_64 x86_64 x86_64 GNU/Linux


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Вт 12 ноя, 2013 8:27 pm 
Не в сети

Зарегистрирован: Вт 29 окт, 2013 12:42 pm
Сообщения: 19
Спасибо, помогло, по-видимому надо было при переделке сделать make clean, а так же с тех пор я перестал собирать пакеты из под sudo, теперь только через su -l root собираю.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пт 08 янв, 2016 6:19 am 
Не в сети
Аватара пользователя

Зарегистрирован: Пн 04 янв, 2016 6:26 pm
Сообщения: 8
С точно такой же ошибкой не собирается textproc/intltool
Код:
checking for perl... (cached) /usr/local/bin/perl
checking for perl >= 5.8.1... 5.20.3
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
===>  Script "configure" failed unexpectedly.
Please report the problem to gnome@FreeBSD.org [maintainer] and attach the
"/usr/obj/usr/ports/textproc/intltool/work/intltool-0.51.0/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/intltool

fidaj писал(а):
прочтите внимательно /usr/ports/UPDATING должно помочь...

А для свежеобновлённой системы, после pkg delete -a тоже должно помочь? А за какую дату читать? :?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пт 08 янв, 2016 12:53 pm 
Не в сети

Зарегистрирован: Вс 05 июн, 2005 4:19 pm
Сообщения: 3073
Откуда: Ukraine
sinaps писал(а):
С точно такой же ошибкой не собирается textproc/intltool
Код:
checking for perl... (cached) /usr/local/bin/perl
checking for perl >= 5.8.1... 5.20.3
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
===>  Script "configure" failed unexpectedly.
Please report the problem to gnome@FreeBSD.org [maintainer] and attach the
"/usr/obj/usr/ports/textproc/intltool/work/intltool-0.51.0/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/intltool

fidaj писал(а):
прочтите внимательно /usr/ports/UPDATING должно помочь...



полная цитата была
fidaj писал(а):
прочтите внимательно /usr/ports/UPDATING на предмет 20131023:

там и стоит дата-строка для поиска по /usr/ports/UPDATING

sinaps писал(а):
А для свежеобновлённой системы, после pkg delete -a тоже должно помочь? А за какую дату читать? :?

для начала нужно определиться - использовать пакеты или порты.
если и первое и второе - то и будут подобные проблемы.

_________________
Ми можемо все - що здатні собі уявити!
uname -a
Linux nonamehost 4.12.12-zen+ #5 ZEN SMP Thu Sep 14 08:50:28 EEST 2017 x86_64 x86_64 x86_64 GNU/Linux


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пт 08 янв, 2016 3:47 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Пн 04 янв, 2016 6:26 pm
Сообщения: 8
fidaj писал(а):
для начала нужно определиться - использовать пакеты или порты.
если и первое и второе - то и будут подобные проблемы.

Порты, только порты.
fidaj писал(а):
там и стоит дата-строка для поиска по /usr/ports/UPDATING

pkg updating perl показывает оттуда то что к Perl относится, только вот там везде пишут про обновление perl с одной версии на другую (с 5.8 на 5.10, с 5.10 на 5.12 и т.д. до с 5.20 до 5.22), а я-то с нуля все пакеты из портов собираю. На момент начала сборки из портов этого /usr/ports/textproc/intltool никаких пакетов в системе не было (pkg delete -a их все удалил), ни из портов собранных ни из репозитория pkg add добавленных.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Сб 09 янв, 2016 7:40 am 
Не в сети
Аватара пользователя

Зарегистрирован: Пн 04 янв, 2016 6:26 pm
Сообщения: 8
Установленными почему-то оказались
Код:
# pkg info
...
perl5-5.20.3_8                 Practical Extraction and Report Language
perl5.16-5.16.3_24             Practical Extraction and Report Language
...


Код:
# pkg info -r perl5-5.20.3_8
perl5-5.20.3_8:
        autoconf-2.69
        clang36-3.6.2
        mc-4.8.15
        llvm36-3.6.2_2
        automake-1.15_1
        glib-2.44.1_2
# pkg info -r perl5.16-5.16.3_24
perl5.16-5.16.3_24:
        p5-Locale-gettext-1.06
        p5-XML-Parser-2.44
#

Обновлять 5.16->5.18->5.20, или можно как-то сразу 5.16->5.20?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Сб 09 янв, 2016 11:41 am 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5334
Откуда: СССР, Харьков
sinaps писал(а):
Обновлять 5.16->5.18->5.20, или можно как-то сразу 5.16->5.20?

Можно.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пн 11 янв, 2016 9:32 pm 
Не в сети
Аватара пользователя

Зарегистрирован: Пн 04 янв, 2016 6:26 pm
Сообщения: 8
ankor писал(а):
Можно.

А как? После
Код:
~ # pkg set -o lang/perl5.16:lang/perl5.20
Change origin from lang/perl5.16 to lang/perl5.20 for all dependencies? [y/N]: y
~ #

Всё равно:
Код:
/usr/ports/textproc/p5-XML-Parser # make all-depends-list
/usr/ports/ports-mgmt/pkg
/usr/ports/lang/perl5.16
/usr/ports/textproc/expat2
/usr/ports/textproc/p5-XML-Parser #

/usr/ports/devel/p5-Locale-gettext # make all-depends-list
/usr/ports/ports-mgmt/pkg
/usr/ports/devel/gettext-tools
/usr/ports/converters/libiconv
/usr/ports/textproc/expat2
/usr/ports/devel/gettext-runtime
/usr/ports/print/indexinfo
/usr/ports/lang/perl5.16
/usr/ports/devel/p5-Locale-gettext #

И portmaster `pkg shlib -qR libperl.so.5.16` начинает пересобирать p5-XML-Parser и p5-Locale-gettext опять с зависимостями от /usr/ports/lang/perl5.16 а не от /usr/ports/lang/perl5.20


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пн 11 янв, 2016 10:11 pm 
Не в сети

Зарегистрирован: Вс 05 июн, 2005 4:19 pm
Сообщения: 3073
Откуда: Ukraine
нужно нормально и правильно обновить порты... (не только дерево портов, но и сами установленные порты)
но я бы рекомендовал составить список используемого ПО, снести все установленные порты - установить пакетами необходимое используемое ПО из списка - а потом уже проводить эксперименты с обновлениями портов.
внимательно читать апдейт файл и выполнять в дальнейшем все инструкции для корректого обновления портов.
а лучше сделать собственную репу и собирать при помощи poudriere со своими необходимыми опциями для портов и уже обновляться пакетно оттуда.
иначе подобные темы будут создаваться чрезмерно часто.

_________________
Ми можемо все - що здатні собі уявити!
uname -a
Linux nonamehost 4.12.12-zen+ #5 ZEN SMP Thu Sep 14 08:50:28 EEST 2017 x86_64 x86_64 x86_64 GNU/Linux


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Вт 12 янв, 2016 4:45 am 
Не в сети
Аватара пользователя

Зарегистрирован: Пн 04 янв, 2016 6:26 pm
Сообщения: 8
fidaj писал(а):
нужно нормально и правильно обновить порты...

Я их не обновляю, а устанавливаю с нуля, в свежеобновлённую сиситему, после удаления с помощью pkg delete -a.
fidaj писал(а):
я бы рекомендовал... снести все установленные порты...

Так и сделал. Но в отличии от первого раза после pkg delete -a снёс ещё и /usr/locale и /var/db и вуаля!
Код:
/usr/ports/textproc/p5-XML-Parser # make all-depends-list
/usr/ports/ports-mgmt/pkg
/usr/ports/lang/perl5.20
/usr/ports/textproc/expat2
/usr/ports/textproc/p5-XML-Parser #

Этого /usr/ports/lang/perl5.16 от которого было непонятно как избавиться больше нету!!!
fidaj писал(а):
...подобные темы будут создаваться чрезмерно часто.

Я надеюсь, что люди с подобной проблемой прочтут эту тему будут иметь в виду, что pkg delete -a кое-где оставляет всякий мусор, и чрезмерно часто не потребуется.
fidaj писал(а):
...а лучше сделать собственную репу и собирать при помощи poudriere со своими необходимыми опциями для портов и уже обновляться пакетно оттуда.

Спасибо за идею, но мне кажется, что это лучше не для моих древних железок. :(


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 14 ] 

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google [Bot], Yahoo [Bot]


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика